Componenti aggiuntivi essenziali per le patch di Elementor Vulnerabilità di sicurezza critica – WP Tavern
Categories
News Sviluppo Realizzazione Siti Web Wordpress Serra Simone

Componenti aggiuntivi essenziali per le patch di Elementor Vulnerabilità di sicurezza critica – WP Tavern

Tempo di lettura: 2 minuti

Componenti aggiuntivi essenziali per Elementor, un popolare plugin con oltre un milione di installazioni attive, ha corretto una vulnerabilità critica ciò consentirebbe un attacco di inclusione di file locali.

La vulnerabilità è stata scoperta dal ricercatore di sicurezza Wai Yan Myo Thet e segnalata a Patchstack il 25 gennaio 2022. I clienti di Patchstack hanno ricevuto una patch virtuale lo stesso giorno. Il problema era già noto agli sviluppatori del plug-in, WPDeveloper, che ha rilasciato due patch insufficienti prima che fosse finalmente risolto nella versione 5.0.5.

Patchstack ha pubblicato un riepilogo della vulnerabilità e ha spiegato come i siti WordPress che utilizzano il plug-in potrebbero essere compromessi:

Questa vulnerabilità consente a qualsiasi utente, indipendentemente dal proprio stato di autenticazione o autorizzazione, di eseguire un attacco di inclusione di file locali. Questo attacco può essere utilizzato per includere file locali nel filesystem del sito Web, come /etc/passwd. Questo può essere utilizzato anche per eseguire RCE includendo un file con codice PHP dannoso che normalmente non può essere eseguito.

È importante notare che la vulnerabilità colpisce principalmente gli utenti che hanno in uso la galleria dinamica e i widget della galleria dei prodotti.

Il registro delle modifiche del plug-in fa sembrare l’aggiornamento più un miglioramento che un serio problema di sicurezza, quindi gli utenti potrebbero non essere pienamente consapevoli della necessità di aggiornare:

5.0.5 – 28/01/2022
Migliorato: maggiore sicurezza per impedire l’inclusione di file indesiderati da server remoto tramite richiesta ajax
5.0.4 – 27/01/2022
Migliorato: percorsi file modello disinfettati per il miglioramento della sicurezza
Aggiunto: supporto per nuove query di capacità per WordPress 5.9
Risolto: i popup di Elementor non venivano attivati
Poche correzioni di bug minori e miglioramenti

Tutte le versioni precedenti alla 5.0.5 sono considerate vulnerabili. Le statistiche di WordPress.org non suddividono le installazioni attive in base alle versioni secondarie, ma circa il 54% degli utenti del plugin esegue versioni precedenti alla 5.0.

Sebbene possa sembrare che più di mezzo milione di utenti siano ancora vulnerabili, dovrebbero anche utilizzare i widget specifici in questione. Se non sei sicuro di utilizzare questi widget in combinazione, è comunque meglio aggiornare semplicemente il prima possibile.


Source link

Web Designer Freelancer Realizzazione Siti Web Serra Simone Realizzo siti web, portali ed e-commerce con focus specifici sull’usabilità, l’impatto grafico, una facile gestione e soprattutto in grado di produrre conversioni visitatore-cliente. Elaboro siti internet, seguendo gli standard Web garantendo la massima compatibilità con tutti i devices. Sviluppo e-commerce personalizzati, multilingua, geolocalizzati per potervi mettere nelle migliori condizioni di vendita. Posiziono il tuo sito su Google per dare maggiore visibilità alla tua attività sui motori di ricerca con SEO di base o avanzato.

Scroll Giù