Google ha pubblicato un aggiornamento al suo Plugin Site Kit per WordPress questo pomeriggio con un hot fix per un problema critico che interessa un numero sconosciuto di utenti. Stavano spuntando segnalazioni di siti Web non funzionanti su Twitter e nel plugin Forum di assistenza su WordPress.org. Gli utenti interessati dal problema hanno segnalato di aver riscontrato un errore critico su tutti i siti che utilizzano Site Kit, che ha forzato la disattivazione del plugin in modalità di ripristino. In alcuni casi ha impedito loro di accedere alle loro dashboard.

“Mercoledì 11 agosto abbiamo identificato un errore irreversibile nel plug-in Site Kit che potrebbe essere attivato da altri plug-in o temi utilizzando una versione senza prefisso di Composer”, ha dichiarato Bethany Chobanian Lang, responsabile del supporto di Google Site Kit, in un appuntato inviare sul forum di supporto.

La versione 1.38.1 contiene una correzione rapida per questo problema, poiché era abbastanza critico da rimuovere i siti Web degli utenti. I manutentori del plugin hanno iniziato indagando sul problema meno di 24 ore fa, ma non sono ancora sicuro di quali plug-in attivino l’errore a causa dell’utilizzo di Composer.

“I rapporti non includono quali plug-in o temi specifici lo stavano causando, ma il messaggio di errore ha evidenziato chiaramente il codice in Site Kit che era il problema”, ha affermato Felix Arntz, ingegnere delle relazioni con gli sviluppatori di Google. “Tecnicamente, quel codice problematico era presente in Site Kit da diverse versioni fa (mesi fa), quindi forse un altro plugin/tema è stato recentemente aggiornato con un nuovo codice che ha esposto il problema.”

Dopo aver esaminato i plugin più diffusi, Arntz ha affermato di non essere stato in grado di trovarne uno che avrebbe innescato il problema. Dato l’ampio utilizzo di Site Kit, altri siti interessati sono destinati a presentarsi una volta che gli utenti si rendono conto dell’esistenza di un problema. Google ha lanciato il plugin nel 2019 e da allora ha accumulato più di un milione di installazioni attive.La maggior parte della base utenti del plug-in esegue versioni precedenti, che potrebbero essere o meno interessate dal problema attuale.

WordPress.org mostra che il 35,6% degli utenti del plugin utilizza la versione 1.38.x. L’hotfix non viene eseguito il backport per le versioni precedenti, ma gli utenti che eseguono Site Kit versione 1.38 con aggiornamenti in background abilitati dovrebbero ricevere automaticamente la correzione.



Source link

Web Designer Freelancer Realizzazione Siti Web Serra Simone Realizzo siti web, portali ed e-commerce con focus specifici sull’usabilità, l’impatto grafico, una facile gestione e soprattutto in grado di produrre conversioni visitatore-cliente. Elaboro siti internet, seguendo gli standard Web garantendo la massima compatibilità con tutti i devices. Sviluppo e-commerce personalizzati, multilingua, geolocalizzati per potervi mettere nelle migliori condizioni di vendita. Posiziono il tuo sito su Google per dare maggiore visibilità alla tua attività sui motori di ricerca con SEO di base o avanzato.